Project

General

Profile

Bug #26

espresso3g/espresso(wifi): graphic glitches on 4.4 UI

Added by Andreas Blaesius over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
% Done:

100%

Device:
espresso, espresso3g

Description

Graphic glitch e.g. in Settings after some time of use.

"The way I'm trying to reproduce it is to open settings, then press home (so it's in ram), then I open as many apps as possible (so settings will be removed from ram) and then open settings again - it should glitch but it's a bit random."

W/GraphicBufferMapper(23730): registerBuffer(0x5eec3ad8) failed -22 (Invalid argument)
E/GraphicBuffer(23730): unflatten: registerBuffer failed: Invalid argument (-22)

After some research i found an intersting post in Galaxy Nexus forum mention https://android-review.googlesource.com/#/c/47932/

seems to solve the issue.

attachment.php.png (97.7 KB) Andreas Blaesius, 03/22/2017 04:24 AM

attachment2.png (75.4 KB) Andreas Blaesius, 03/22/2017 04:24 AM

aosp_logs.zip (64.9 KB) Andreas Blaesius, 03/22/2017 04:25 AM

16
17

History

#1 Updated by Andreas Blaesius over 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 50

"(...)so far it works fine and I was using it a lot, it seems like issue is fixed at least I hope so, although I would wait with final verdict for few days more but it seems for me like my longest glitch free AOSP run ever(...)"

Let's wait some more days for feedback again.

#2 Updated by Andreas Blaesius over 2 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 50 to 100

No problems since 1 Week, good to go!

#3 Updated by Andreas Blaesius almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF